STR #1978

FLTK matrix user chat room
(using Element browser app)   FLTK gitter user chat room   GitHub FLTK Project   FLTK News RSS Feed  
  FLTK Apps      FLTK Library      Forums      Links     Login 
 Home  |  Articles & FAQs  |  Bugs & Features  |  Documentation  |  Download  |  Screenshots  ]

Return to Bugs & Features | Roadmap 2.0 | Post Text | Post File | SVN ⇄ GIT ]

STR #1978

Application:FLTK Library
Status:5 - New
Priority:1 - Request for Enhancement, e.g. asking for a feature
Scope:3 - Applies to all machines and operating systems
Summary:There is a fair amout of "kruft" in fuction names
Created By:craigd
Assigned To:Unassigned
Fix Version:Unassigned
Update Notification:

Receive EMails Don't Receive EMails

Trouble Report Files:

Post File ]

No files

Trouble Report Comments:

Post Text ]
Name/Time/Date Text top right image
#1 craigd
01:30 Jun 11, 2008
There is a fair amount of what I'd call "kruft" and inconsistencies in the function names of 2.0. Assuming 2.0 is a clean up rev, it could be an opportunity to address these. For example, most of the "set*" functions are "set_" but setcolor, setTextColor, setPixel, setcell exist, which differ in "_" and case.
Another example is Tooltip::enabled, enable, and disable. I'd like to see these collapsed into one function: enabled([b]). The various names may have made sense in a C world but not in overloaded C++ [aside: I'm coming at this as someone who is writing a language binding, and would rather write/understand 1 function instead of 3).
#2 craigd
01:40 Jun 11, 2008
Addition to last comment: If it is not reasonable to collapse stuff like enabled/enable/disable, it would be nice to at least pick one and overload it so the others can be ignored.  
bottom left image   bottom right image

Return to Bugs & Features | Post Text | Post File ]


Comments are owned by the poster. All other content is copyright 1998-2024 by Bill Spitzak and others. This project is hosted by The FLTK Team. Please report site problems to ''.