STR #1205

FLTK matrix user chat room
(using Element browser app)   FLTK gitter user chat room   GitHub FLTK Project   FLTK News RSS Feed  
  FLTK Apps      FLTK Library      Forums      Links     Login 
 Home  |  Articles & FAQs  |  Bugs & Features  |  Documentation  |  Download  |  Screenshots  ]
 

Return to Bugs & Features | Roadmap 1.1 ]

STR #1205

Application:FLTK Library
Status:1 - Closed w/Resolution
Priority:3 - Moderate, e.g. unable to compile the software
Scope:2 - Specific to an operating system
Subsystem:X11
Summary:Under Xft, the first call to fl_font() crashes if its arguments are both 0
Version:1.1.7
Created By:jeremy_henty
Assigned To:matt
Fix Version:1.1-current (SVN: v5035)
Update Notification:

Receive EMails Don't Receive EMails

Trouble Report Files:


Name/Time/Date Filename/Size top right image
 
#1 jeremy_henty
09:37 Mar 18, 2006
xft_fl_font_patch
1k
 
bottom left image   bottom right image

Trouble Report Comments:


Name/Time/Date Text top right image
 
#1 jeremy_henty
09:37 Mar 18, 2006
When rendering with Xft, if the first call to fl_font() is fl_font(0,0)
then the application segfaults.  This happens because the code
dereferences fl_fontsize, which is NULL when fl_font() is first called.

The attachment is a one-line patch to src/fl_font_xft.cxx that fixes
the problem.
 
 
#2 matt
06:55 Apr 27, 2006
Fixed in Subversion repository.


fl_font(0, 0) as a first call in Xft would try to access a member in fl_fontsize, which was still set to NULL. This fix is untersted as I don't have a Unix machine here. Please verify this fix!
 
bottom left image   bottom right image

Return to Bugs & Features ]

 
 

Comments are owned by the poster. All other content is copyright 1998-2022 by Bill Spitzak and others. This project is hosted by The FLTK Team. Please report site problems to 'erco@seriss.com'.