Re: [HIGH] STR #3514: Bundled image libs on Linux are incompatible with Xft

FLTK matrix user chat room
(using Element browser app)   FLTK gitter user chat room   GitHub FLTK Project   FLTK News RSS Feed  
  FLTK Apps      FLTK Library      Forums      Links     Login 
 All Forums  |  Back to fltk.bugs  ]
 
Previous Message ]New Message | Reply ]Next Message ]

Re: [HIGH] STR #3514: Bundled image libs on Linux are incompatible with Xft Albrecht Schlosser 04:31 Nov 16 top right image
 
[STR Closed w/Resolution]

Link: https://www.fltk.org/str.php?L3514
Version: 1.4-current
Fix Version: 1.4.0
Git Commit: 796a9bf23e63dfc6834b9fd04c10c8c27f894941


Fixed in Git repository.

FTR: After recent issues caused by incompatible Xft and image libraries
we decided to prefix the bundled image libs with 'fltk_' to avoid
conflicts. References:

- STR 3347: prefixing embedded jpeg/png/zlib symbols

- STR 3514: Bundled image libs on Linux are incompatible with Xft

- GitHub Issue #232: [fltk 1.4.x/Linux] application invoking native
  filechooser crashes under linux if fltk built with --enable-localpng

- GitHub Issue #289: Printing without and with GTK

- GitHub PR #292: Prefix bundled libs

- Git merge commit: 796a9bf23e63dfc6834b9fd04c10c8c27f894941

@djcj/darealshinji: Thanks for the patches, particularly jpeg-9b.patch.
  I used it in a modified form.


Link: https://www.fltk.org/str.php?L3514
Version: 1.4-current
Fix Version: 1.4.0
Git Commit: 796a9bf23e63dfc6834b9fd04c10c8c27f894941


Direct Link to Message ]
 
bottom left image   bottom right image
Previous Message ]New Message | Reply ]Next Message ]
 
 

Comments are owned by the poster. All other content is copyright 1998-2022 by Bill Spitzak and others. This project is hosted by The FLTK Team. Please report site problems to 'erco@seriss.com'.