Re: [MOD] STR #3531: abi-version.h not created/changed by ./configure

GitHub FLTK Project   FLTK News RSS Feed  
  FLTK Apps      FLTK Library      Forums      Links     Login 
 All Forums  |  Back to fltk.bugs  ]
 
Previous Message ]New Message | Reply ]Next Message ]

Re: [MOD] STR #3531: abi-version.h not created/changed by ./configure Albrecht Schlosser Nov 12, 2019 top right image
 
DO NOT REPLY TO THIS MESSAGE.  INSTEAD, POST ANY RESPONSES TO THE LINK BELOW.

[STR Pending]

Link: https://www.fltk.org/str.php?L3531
Version: 1.3.5
Fix Version: None


Okay, thanks for your quick reply. I can see your problem.

But to preserve binary compatibility we need to configure with the default
binary version 1.3.0 if nothing else is given on the command line. This is
intended for building shared FLTK libs and also Unix/Linux and other
distros to maintain binary compatibility among 1.3.x versions.

ABI features are *only* enabled if you *explicitly* invoke `./configure
--with-abiversion=103xx'. Maybe this is not documented clearly enough, but
this is not going to be changed for reasons mentioned above.

Your example with FL_TREE_REASON_RESELECTED doesn't seem to be documented
correctly as ABI 1.3.1 feature which it should obviously be (unless I'm
missing something). But since 1.3.x is at its end of development this will
likely not be changed. Sorry.

Can we close this STR?

PS: if you'd like to discuss this or similar issues, fltk.coredev is the
proper place. Thank you.
https://groups.google.com/forum/#!forum/fltkcoredev


Link: https://www.fltk.org/str.php?L3531
Version: 1.3.5
Fix Version: None


Direct Link to Message ]
 
bottom left image   bottom right image
Previous Message ]New Message | Reply ]Next Message ]
 
 

Comments are owned by the poster. All other content is copyright 1998-2021 by Bill Spitzak and others. This project is hosted by The FLTK Team. Please report site problems to 'erco@seriss.com'.