STR #1980

  
  FLTK Apps      FLTK Library      Forums      Links     Login 
 Home  |  Articles & FAQs  |  Bugs & Features  |  Documentation  |  Download  |  Screenshots  ]
 

Return to Bugs & Features | Post Text | Post File | Prev ]

STR #1980

Application:FLTK Applications
Status:5 - New
Priority:3 - Moderate, e.g. unable to compile the software
Scope:3 - Applies to all machines and operating systems
Subsystem:Unassigned
Summary:flphoto will not compile due to configure script not detecting jgep and png
Version:-current
Created By:johnh123
Assigned To:Unassigned
Fix Version:Unassigned
Update Notification:

Receive EMails Don't Receive EMails


Trouble Report Files:

Post File ]

No files


Trouble Report Comments:

Post Text ]
Name/Time/Date Text
 
#1 johnh123
02:55 Jun 14, 2008
The configure script fails to detect libjpeg and libpng (both libraries and dev packages are correctly installed), the output of fltk-config is below. To work around I added --ldstaticflags to the fltk-config commands in configure then config.h had HAVE_LIBJPEG and HAVE_LIBPNG defined, flphoto then compiled and works correctly. This issue is not resolved by installing fltk v1.1.9 as --ldflags does not return -ljpeg -lpng either. This is on Ubuntu 7.10

As in configure.in
$ fltk-config --use-images --ldflags
-lfltk_images -lfltk

Static flags
$ fltk-config --use-images --ldstaticflags
/usr/lib/libfltk_images.a -lpng -ljpeg /usr/lib/libfltk.a -lXft -lXinerama -lpthread -lm -lX11
 
 
 
 

Comments are owned by the poster. All other content is copyright 1998-2015 by Bill Spitzak and others. This project is hosted by Seriss Corporation. Please report site problems to 'erco@seriss.com'.